MySecureDesktop Outage

Major incident MySecureDesktop Cloud Services Cloud - FICS Hosting Platform Cloud - Hosted Desktop Service Cloud - Hosted Microsoft Dynamics CRM Services Cloud - Hosted Microsoft Dynamics GP Services
2021-05-28 21:30 UTC · 16 minutes, 52 seconds

Updates

Resolved

The Cloud services team identified an issue with the storage subsystem and addressed it. The MySecureDesktop service is now back online.

We apologize for the inconvenience this has caused. If you are experiencing any issues, please contact us at help@acsicorp.com.

May 28, 2021 · 21:47 UTC
Investigating

We are currently seeing a number of our MySecureDesktop sessions stuck in a frozen state. This is causing MySecureDesktop users not to be able to access the service. The Cloud team is currently investigating the cause of this issue and working to restore service.

May 28, 2021 · 21:32 UTC

← Back