Mail Flow / DNS Outage

Major incident ACS Solutions Hosted Microsoft Exchange Services ACS Solutions EdgePilot - E-mail Filtering Services Hosted Microsoft Exchange 2019 Hosted Microsoft Exchange 2016
2021-08-10 15:23 UTC · 2 hours, 30 minutes, 50 seconds

Updates

Resolved

This incident is now resolved.

August 10, 2021 · 17:54 UTC
Monitoring

Our Engineering team was able to Resolve the the DNS issue impacting multiple services including our Hosted Exchange (HEX) and all threat solutions; causing mail delays and MS Outlook disconnects. We will continue to monitor the situation and sincerely apologize for any inconvenience and understand the importance of timely mail flow.

August 10, 2021 · 17:03 UTC
Investigating

Our Engineering team continues to work on the DNS issue impacting multiple services including our Hosted Exchange (HEX) and all Threat solutions.

August 10, 2021 · 16:35 UTC
Investigating

Our Engineering team continues to work on the DNS issue impacting multiple services including our Hosted Exchange (HEX) and all threat solutions; causing mail delays and MS Outlook disconnects.

Some messages sent may be returned to the sender as undelivered.

We apologize for the inconvenience and are diligently working to resolve this issue as soon as possible.

August 10, 2021 · 16:00 UTC
Investigating

Our Engineering team has found and are working on a DNS issue impacting multiple services including our Hosted Exchange and all Threat Solutions causing mail delays and Outlook disconnects. We apologize for the inconvenience and are working to resolve it as soon as possible.

August 10, 2021 · 15:24 UTC

← Back