Hosted Exchange / Data Center Issues

Minor incident ACS Solutions Hosted Microsoft Exchange Services ACS Solutions EdgePilot - E-mail Filtering Services Hosted Microsoft Exchange 2019 Hosted Microsoft Exchange 2016
2022-02-10 15:51 UTC · 10 hours, 20 minutes, 28 seconds

Updates

Resolved

Our Engineers are continuing to work diligently to get the data center back to normal operational status and going through each service to verify system status. Mail systems have been restored and are currently working through the backlog of queued messages.

We apologize for any inconvenience this is currently causing.

February 11, 2022 · 02:11 UTC
De-escalate

Our Engineers are continuing to work and make progress in getting the data center back to normal operational status. Some mail systems have been restored and is currently working through the backlog of queued messages. We apologize for any inconvenience this is currently causing.

February 10, 2022 · 20:51 UTC
Update

Our Engineers are continuing to work and make progress in getting the datacenter back to normal operational status. We are aware of some mail flow issues for the Encryption and Threat systems. We apologize for any inconvenience this is currently causing.

February 10, 2022 · 18:37 UTC
Update

Our engineering team is still actively working on this issue and has made progress. They are beginning to see the datacenter return to normal operational status. We are continuing to work and rectify the issue. We apologize for any inconvenience this is currently causing.

February 10, 2022 · 17:13 UTC
Investigating

We are currently experiencing an issue with one of our main data centers where our Hosted Microsoft Exchange environment lives. This will affect customer portal access and mail delivery. Our team is working to identify the cause of the issue and we will provide further updates as they become available.

We apologize for the inconvenience this has caused you.

February 10, 2022 · 15:53 UTC

← Back