Support Email Address Issues

Major incident ACS Solutions Service Desk Zendesk Service Desk Portal
2022-04-06 19:55 UTC · 3 minutes, 8 seconds

Updates

Resolved

This incident is now resolved.

April 6, 2022 · 19:58 UTC
Issue

We experienced an issue earlier today where our service desk e-mail address was not delivering those support e-mails to our service desk platform. This was being caused by an issue within the Office 365 platform and has now been resolved.

If you sent an e-mail to help@acsicorp.com and did not receive an auto response advising you that a ticket had been created, we did not receive your e-mail. Please resend your request or give us a call at (888) 588-4131. We apologize for the inconvenience.

April 6, 2022 · 19:58 UTC

← Back